Difference between revisions of "Category:Rational Developer"

From MidrangeWiki
Jump to: navigation, search
(Version history: +8.0.0, 8.0.3, 8.5.0)
(Updated eclipse versions)
Line 142: Line 142:
 
| [http://www-01.ibm.com/common/ssi/cgi-bin/ssialias?subtype=ca&infotype=an&appname=iSource&supplier=897&letternum=ENUS210-360 8.0]   
 
| [http://www-01.ibm.com/common/ssi/cgi-bin/ssialias?subtype=ca&infotype=an&appname=iSource&supplier=897&letternum=ENUS210-360 8.0]   
 
|Oct 2010
 
|Oct 2010
| 3.4?
+
| 3.6
 
|-
 
|-
 
| 7.1
 
| 7.1
Line 148: Line 148:
 
| [http://www-01.ibm.com/common/ssi/cgi-bin/ssialias?subtype=ca&infotype=an&appname=iSource&supplier=897&letternum=ENUS211-344 8.0.3]   
 
| [http://www-01.ibm.com/common/ssi/cgi-bin/ssialias?subtype=ca&infotype=an&appname=iSource&supplier=897&letternum=ENUS211-344 8.0.3]   
 
|Oct 2011
 
|Oct 2011
| 3.4?
+
| 3.6
 
|-
 
|-
 
| 7.1
 
| 7.1
Line 154: Line 154:
 
| [http://www-01.ibm.com/common/ssi/ShowDoc.wss?docURL=/common/ssi/rep_ca/9/877/ENUSZP12-0219/index.html&lang=en&request_locale=en 8.5]   
 
| [http://www-01.ibm.com/common/ssi/ShowDoc.wss?docURL=/common/ssi/rep_ca/9/877/ENUSZP12-0219/index.html&lang=en&request_locale=en 8.5]   
 
|May 2012  
 
|May 2012  
| 3.4?
+
| 3.6
 
|}
 
|}
  

Revision as of 10:39, 17 July 2012

Rational Developer, an acronym for WebSphere Development Studio Client for System i, is a robust, Windows-based, integrated development environment (IDE) based on the open source Eclipse project that is customized for System i developers. WDSC's predecessor was Code/400. The current product replacing WDSC is Rational Development for Power Systems for i, generally called RDp for the sake of brevity.

WDSC has support for editing various types of files...

Additionally, it contains...

WDSC has been superseded in i 6.1 by IBM Rational Software Delivery Platform for System i WDSC was originally still orderable in i 6.1, but as of April 2010, WDSC is no longer supported [1]. The successor to RDi is RDp.

Plug-Ins

WDSC/RDi/RDp use the same plug-in mechanism as Eclipse (since they are based on Eclipse), with some modifications to support the RSE.

A number of vendors have plug-ins for their specific product, and there are some open-source plug-ins available. See WDSC/Plugin.

Compatiblity

In general ...

  • Plug-in's designed for Eclipse 3.2 will work with WDSC 7.0 and RDi 7.1
  • Plug-in's designed for Eclipse 3.4 will work with RDi 7.5 and RDp 7.5 & higher.

NOTE:

  • Plug-in's designed for WDSC 7.0 and RDi 7.1 are compatible.
  • Plug-in's designed for RDi 7.5 and RDp 7.5 & higher are compatible.

Version history

This version history needs review![verification needed]

i5/OS version Tool name Tool version Release date Eclipse version
V3R1 ADTS CS/400 V3R1?  ??
V3R2 ADTS CS/400 V3R2  ??
V3R7 ADTS CS/400 V3R7 (unchanged from V3R6?) 1995?  ??
V4R1 ADTS CS/400 V3R7 (unchanged from V3R6?) 1996?  ??
V4R2 ADTS CS/400 V4R2 1997?  ??
V4R3 ADTS CS/400 V4R2 1997?  ??
V4R4 ADTS CS/400 V4R4 1999?  ??
V4R5 ADTS CS/400 V4R5 2000?  ??
V5R1 WDS V5.0 January 2003  ??
V5R2 WDS V5.0, 5.1 January 2003  ??
V5R3 WDS V6.0 May 2004 3.0
V5R4 WDSCi 7.0 January 2006 3.2
6.1 RDi 7.1 January 2008 3.2
6.1 RDi 7.5 October 2008 3.4
6.1 RDP 7.5 February 2010 3.4?
7.1 RDP 7.6 April 2010 3.4
7.1 RDP 8.0 Oct 2010 3.6
7.1 RDP 8.0.3 Oct 2011 3.6
7.1 RDP 8.5 May 2012 3.6

References

  1. V6R1 and 7.1 Announcement summary Retrieved on 4 Jun 2010

External links

This category currently contains no pages or media.