Difference between revisions of "WDSC tips"

From MidrangeWiki
Jump to: navigation, search
(Split Find into a sub page)
m (fix link)
 
(41 intermediate revisions by 3 users not shown)
Line 1: Line 1:
__FORCETOC__
 
 
This is a dump of tips gathered from the [[WDSCI-L]] list.
 
This is a dump of tips gathered from the [[WDSCI-L]] list.
  
==EDITOR==
+
Additional tips for Lpex [[WDSC_LPEX|can be found here]]
See [[/Editor]]
 
  
==COMPILE==
+
The tips are split up into sub-pages. 
See [[/Compile]]
 
  
==FIND ==
+
To see the tips please click on a link below.
See [[/Find]]
 
  
==DEBUG==
+
==[[/Editor]]==
 +
* [[WDSC shortcuts|Keyboard Shortcuts]]
 +
* [[WDSC tips/Editor#Editor Commands|Editor Commands]]
 +
* [[WDSC tips/Editor#WDSCi vs SEU F15=Browse options|WDSCi vs SEU F15=Browse options]]
 +
* [[WDSC tips/Editor#Position my cursor to where I need to key additional data. (On IBM rqmts list)|Position my cursor to where I need to key additional data. (On IBM rqmts list)]]
 +
* [[WDSC tips/Editor#Do I have to use the mouse to copy lines from one member to another?|Do I have to use the mouse to copy lines from one member to another?]]
 +
* [[WDSC tips/Editor#How can I copy field names in to the member? (On IBM rqmts list)|How can I copy field names in to the member? (On IBM rqmts list)]]
 +
* [[WDSC tips/Editor#Can I condition page ups and downs by cursor position?|Can I condition page ups and downs by cursor position?]]
 +
* [[WDSC tips/Editor#Do I have to continually save my work?|Do I have to continually save my work?]]
 +
* [[WDSC tips/Editor#Auto Marking Changes to the Source|Auto Marking Changes to the Source]]
 +
* [[WDSC tips/Editor#How do I shift a block of text left/right?|How do I shift a block of text left/right?]]
 +
* [[WDSC tips/Editor#Vertical line in WDSCI editor|Vertical line in WDSCI editor]]
 +
* [[WDSC tips/Editor#Prevent Enter generating a new line|Prevent Enter generating a new line]]
 +
* [[WDSC tips/Editor#To Print RPG Indented Source|To Print RPG Indented Source]]
 +
* [[WDSC tips/Editor#To show dates for source lines:|To show dates for source lines:]]
 +
* [[WDSC tips/Editor#See SQL HOST variables in OUTLINE view. (is not possible)|See SQL HOST variables in OUTLINE view. (is not possible)]]
 +
* [[WDSC tips/Editor#Downloading source to PC to work offline|Downloading source to PC to work offline]]
 +
* [[WDSC tips/Editor#OFFLINE work vs ONLINE |OFFLINE work vs ONLINE ]]
 +
* [[WDSC tips/Editor#Fast Open another Source|Fast Open another Source]]
 +
* [[WDSC tips/Editor#Record/Playback for Signature marks|Record/Playback for Signature marks]]
 +
* [[WDSC tips/Editor#Field Exit|Field Exit]]
 +
* [[WDSC tips/Editor#Automatic structure completion|Automatic structure completion]]
 +
* [[WDSC tips/Editor#Enter Key not Working|Enter Key not Working]]
 +
* [[WDSC tips/Editor#Snippets|Snippets]]
 +
* [[WDSC tips/Editor#Switch Auto Syntax Check On/Off|Switch Auto Syntax Check On/Off]]
 +
* [[WDSC tips/Editor#CL auto format|CL auto format]]
 +
* [[WDSC tips/Editor#Show fields in a file|Show fields in a file]]
 +
* [[WDSC tips/Editor#Refresh Cache for New Field|Refresh Cache for New Field]]
 +
* [[WDSC tips/Editor#Work on a fix while keeping another project open|Work on a fix while keeping another project open]]
 +
* [[WDSC tips/Editor#Tracking Source changes|Tracking Source changes]]
 +
* [[WDSC tips/Editor#Column Sensitive Editing|Column Sensitive Editing]]
 +
* [[WDSC tips/Editor#Block Nesting|Block Nesting]]
 +
* [[WDSC tips/Editor#View Source Side By Side|View Source Side By Side]]
 +
* [[WDSC tips/Editor#Refreshing the Project Perspective|Refreshing the Project Perspective]]
 +
[[#top]]
  
===Debug and SEP Service entry prints===
+
==[[/Compile]]==
original post [http://archive.midrange.com/wdsci-l/200403/msg00133.html]
 
(the post contains a lot of other information)
 
  
*In Iseries Table View
+
* [[WDSC tips/Compile#RPG source was not being saved|RPG source was not being saved]]
*Right Click on the Source
+
* [[WDSC tips/Compile#Error-messages are still showing in the edit view|Error-messages are still showing in the edit view]]
*Select Debug(service Entry)/Set Service Entry Point
+
* [[WDSC tips/Compile#SQLRPGLE Compiles how to find Compile errors|SQLRPGLE Compiles how to find Compile errors]]
*Next Panel Click OK (I have not done Service Programs)
+
* [[WDSC tips/Compile#Within RSE, how to compile Interactively versus Batch|Within RSE, how to compile Interactively versus Batch]]
*If you get a 'Iseries Debug Message has not been started yet' message, follow the instruction, then try again.
+
* [[WDSC tips/Compile#Custom Compile Commands|Custom Compile Commands]]
*When the SEP is is set click OK.
+
[[#top]]
*Run the program, however you normally would, eg. call, menu option, whatever.
+
==[[/Find]]==
*You need to run the program under the User Profile in the SEP
 
Check [[Service Entry Point]], if you need to change the user profile of the SEP.
 
*The WDSC Debug view should pop up and you can set breakpoints view variables etc. etc. check [[Interactive debugger|Interactive Debugger]]
 
Return to [[#TOP]]
 
  
===Clear Breakpoints===
+
* [[WDSC tips/Find#Scan for a date when source lines were changed (like F14 in SEU)|Scan for a date when source lines were changed (like F14 in SEU)]]
original post [http://archive.midrange.com/wdsci-l/200612/msg00271.html]
+
* [[WDSC tips/Find#Find Tips|Find Tips]]
 +
* [[WDSC tips/Find#Find Field usage (for SQL where OUTLINE doesnt work)|Find Field usage (for SQL where OUTLINE doesnt work)]]
 +
* [[WDSC tips/Find#Search|Search]]
  
*In the Debug perspective
 
*Click the Breakpoints tab
 
*There is an icon, (looks like a double X) to remove all Breakpoints
 
  
You can manage ALL of your breakpoints across multiple programs and
+
[[#top]]
multiple languages, both on the client and on the server.
 
You can enable and disable them, as well as remove them entirely.
 
  
Return to [[#TOP]]
+
==[[/DEBUG]]==
  
===Field Values===
+
* [[WDSC tips/DEBUG#Debug and SEP Service Entry Points|Debug and SEP Service Entry Points]]
original post [[http://archive.midrange.com/wdsci-l/200612/msg00250.html]]
+
* [[WDSC tips/DEBUG#UPDPROD (*YES)|UPDPROD (*YES)]]
 
+
* [[WDSC tips/DEBUG#Clear Breakpoints|Clear Breakpoints]]
*Window -> Preferences -> Run/Debug -> Compiled Debug
+
* [[WDSC tips/DEBUG#Field Values|Field Values]]
*Check Tick, 'Always use Debugger Editor while debugging'
+
* [[WDSC tips/DEBUG#Debug Breakpoints not breaking|Debug Breakpoints not breaking]]
 
+
* [[WDSC tips/DEBUG#Debug a crashed Job|Debug a crashed Job]]
FWIW  I also Check Tick 
+
* [[WDSC tips/DEBUG#Debug server not starting|Debug server not starting]]
*Allow hover evaluation
+
* [[WDSC tips/DEBUG#Displaying the Contents of a Table|Displaying the Contents of a Table]]
*Double-Click in Debugger Editor to add monitored expression
+
[[#top]]
*Centre view on execution line 
 
([[User:FKOL|FKOL]] 21:17, 4 February 2008 (CST))
 
 
 
In V6.0, the debugger started to use iSeries Editor as the default editor
 
to display the source.  The fly over expression evaluation was available
 
in OPM RPG, ILE RPG and ILE COBOL. 
 
 
 
Return to [[#TOP]]
 
 
 
===Debug Breakpoints not breaking===
 
original post [[http://archive.midrange.com/wdsci-l/200802/msg00698.html]]
 
 
 
When Debugging also when debugging SQLRPGLE
 
 
 
*Use listing view
 
*Turn off all caching. Window -> Preferences -> Remote systems -> File Cache, ______ Click 'Clear cached files'
 
*Window -> Preferences -> Remote systems -> iSeries -> Cache, ______  Check 'disable caching' and click on the 'Clear cache' button.
 
*Refresh the  table view often, especially before setting the SEP.
 
 
 
Return to [[#TOP]]
 
 
 
==SETUP==
 
 
 
===User Actions ===
 
 
 
Check [[RSE#Running a user action|User Action]]
 
 
 
Return to [[#TOP]]
 
 
 
===What are Profiles and Filter Pools for ===
 
Check [[Profiles, Connections, and Filters]]
 
 
 
Check [[RSE filter]]
 
 
 
Return to [[#TOP]]
 
 
 
 
 
===Remap Keyboard Shortcuts===
 
Check [[WDSC LPEX#Remap keyboard shortcuts|remap shortcuts]]
 
 
 
Check [[WDSC shortcuts]]
 
 
 
Return to [[#TOP]]
 
 
 
===Other Language Setup (Japanese)===
 
original post[[http://archive.midrange.com/wdsci-l/200606/msg00141.html]]
 
 
 
The assumption made is that your PC is set up to your preferred languange and the fonts are available on the PC.
 
 
 
*In Window -> Preferences -> Lpex Editor -> Appearance
 
*Change the font to the appropriate language.
 
 
 
Return to [[#TOP]]
 
 
 
==MISC==
 
 
 
 
 
===RSEF1002E Error ===
 
 
 
Operation failed. File system input or output error.
 
*Exit WDSCi and reboot your PC.
 
*I changed my password recently. For some reason my password got disabled. Also my Netserver password was disabled. (see Disabled User IDs in Netserver via Navigator.)
 
*I reset my password, had my Netserver ID enabled and rebooted, all was OK.
 
 
 
original post [[User:FKOL|FKOL]] 05:17, 11 December 2007 (CST)
 
 
 
Return to [[#TOP]]
 
 
 
===Easy Source Upload===
 
original post [http://archive.midrange.com/wdsci-l/200710/msg00169.html]
 
(This came from the comment about copying source between systems)
 
 
 
 
 
*There are lots of useful RPG sources posted on the net,
 
*But , How do I get that source into my source file.
 
 
 
WELL  WDSCi is a really simple method to upload the source.
 
 
 
*Mark and copy the source you found on the net.
 
*In RSE use CRTL-Shift-A to open a source member into your favourite library/file. (Member will be created if it does not exist)
 
*Paste the source code and save it (CRTL-S is one way to save)
 
*Voila the source is now yours!!
 
 
 
Return to [[#TOP]]
 
 
 
 
 
===The outline view of the RPG (or other) program doesn't show the fields TEXT.===
 
original post [http://archive.midrange.com/wdsci-l/200706/msg00409.html]
 
 
 
The outline view of the RPG (or other) program doesn't have any way to show the TEXT associated with the field in a file, but:-
 
 
 
*You can easily open the Field Table View that does.
 
*This will open the iSeries Field Table View which gives all the field information.
 
#Right-click on the line with the F-spec
 
#Select the Show fields menu option.
 
 
 
 
 
*To show the properties of fields in files.
 
#Right click on a physical file object in RSE tree view
 
#and select show in table -> fields. 
 
 
 
 
 
*If you are using 7.0, you are also able to bring up a Field Table View by highlighting any (PF, LF, DSPF, etc...) file in an RPG program's F-Specs then select Source->Show Fields from the Menu Bar.
 
 
 
*The above tips only work if the file is externally described in the F specification.
 
 
 
Return to [[#TOP]]
 
 
 
===List libs, objects, members, etc with descriptions?===
 
original post [http://archive.midrange.com/wdsci-l/200706/msg00409.html]
 
 
 
Is there a way to list libs, objects, members, etc in the Remote Systems view with descriptions?
 
*The tree view doesn't support this - although if you look at the properties view - you will see the description when an item is selected in the tree view. 
 
*You should probably try the table view.  Window>Show View>Other (or iSeries Table View)
 
 
 
Return to [[#TOP]]
 
 
 
 
 
===SQL result set only contains 50 rows ===
 
original post [http://archive.midrange.com/wdsci-l/200711/msg00254.html]
 
 
 
You need to open the Data View to enable this preference.
 
*Window -> Preference -> Data -> Sql Query  that lets you specify the maximum number of rows to return,
 
*as well as maximum bytes to retrieve for large columns.
 
*The default max number of rows is 50.
 
*Get V7 if you can.
 
 
 
Return to [[#TOP]]
 
 
 
===I have these strange square symbols in my code.===
 
ref [[User: PabloMotte| PabloMotte]], 27 November 2007 (CST)
 
 
 
When you are in RS LPEX, right-click and select Source>Hex Edit line,  you will then see the hex value in the iSeries codepage, along with the client codepage.
 
 
 
Also, you can put the cursor on the square, press ESC (to move to the command line) and type "query hex". The "set hex 84" command will set the current cursor position to hex 84 (which turns on 'underline' for the SEU display).
 
* Examples of hex codes you can use with "set hex"
 
** 80 Normal     
 
** 81 Inverse     
 
** 82 White       
 
** 83 Inverse White
 
** 84 Underline   
 
** 88 Red
 
 
 
Return to [[#TOP]]
 
 
 
===Run a program on your PC===
 
original post [http://archive.midrange.com/wdsci-l/200711/msg00213.html]
 
 
 
There are several programs that come with System i Access for Windows that can be interesting to use, but you can run other programs on your PC too.  Those programs are {{code|wrksplf, wrkmsg, wrkprt and wrkusrj}} They are found in the System i Access program folder.  On my default install, that is {{code|C:\Program Files\IBM\Client Access}}  To register one of these programs in WDSC 7.0.0.x, take the following steps:
 
* Run (from the menu.)
 
* External Tools and then select (again) External Tools.
 
* Click on the Program config once to select it.
 
* Click on the New Launch Config icon on the far left (the one with the plus sign) at the top of the panel.
 
** In the Main tab:
 
*** In the Name box I entered the name of the .exe (e.g. Wrksplf)
 
*** In 'Location' click 'browse file system' and drill to the exe in the IBM Client access folder and select the exe. 
 
*** In 'Working Directory', copy & paste the path and strip off the final slash and the name of the .exe
 
** In the Common tab:
 
*** In the middle, Display in favorites menu, select 'External Tools' and the new application will show up under {{code|Run->External tools}}
 
** Click apply, then run to test. Close the app.
 
 
 
When you select {{code|Run->External Tools}} again it should appear at the top of the context menu. You can change the order they appear on the {{code|Run->External Tools}} context menu by using {{code|Run->External Tools->Organize favorites}}
 
 
 
Return to [[#TOP]]
 
 
 
 
 
===Where can I find a list of enhancements in V7?===
 
original post [http://archive.midrange.com/wdsci-l/200706/msg00409.html]
 
 
 
You can find the list here: [http://www-306.ibm.com/software/awdtools/wdt400/news/ga700.html]
 
 
 
===How do you work through learning the functionality of this application?=== 
 
original post [http://archive.midrange.com/wdsci-l/200706/msg00409.html]
 
 
 
*Currently I'm just stumbling through the basics, and I know I'm not doing many things the most productive way.
 
*I recommend that you try the tutorials included in the product as well as the PDM/SEU transition to RSE/LPEX - which was revamped and rewritten for v7.0. 
 
*Also, if you go to the WDSC web site [http://www.ibm.com/software/awdtools/wdt400] and search the support section - you will find additional tutorials and the labs from COMMON.
 
 
 
*Don Nitke has a site with a bunch of tutorials at [http://www.modernrpgiv.com/]
 
 
 
*Joe Pluta adds:
 
You can use the help and tutorials from within the product itself. 
 
There are some free tutorials out on the web, including my own first one.
 
You can buy my book, WDSC: Step by Step, which is based on version 5.1.2, but still pretty valid.
 
You can buy my training course from Rochester Initiative which is now available for version  7. 
 
*You can go to a jumpstart at a technical conference, or an all-day standalone seminar sponsored by your local user group. 
 
*Or you can contract with someone to come onsite and provide training.
 
 
 
Return to [[#TOP]]
 
  
 +
==[[/SETUP]]==
  
 +
* [[WDSC tips/SETUP#User Actions|User Actions]]
 +
* [[WDSC tips/SETUP#What are Profiles and Filter Pools for|What are Profiles and Filter Pools for]]
 +
* [[WDSC tips/SETUP#Remap Keyboard Shortcuts|Remap Keyboard Shortcuts]]
 +
* [[WDSC tips/SETUP#Other Language Setup (Japanese font)|Other Language Setup (Japanese font)]]
 +
* [[WDSC tips/SETUP#Error Installing WDSC 7|Error Installing WDSC 7]]
 +
* [[WDSC tips/SETUP#Missing Filter Option|Missing Filter Option]]
 +
* [[WDSC tips/SETUP#Ghost Image for Install V6|Ghost Image for Install V6]]
 +
* [[WDSC tips/SETUP#V7 Turbo Boost|V7 Turbo Boost]]
 +
[[#top]]
 +
==[[/MISC]]==
  
 +
* [[WDSC tips/MISC#RSEF1002E Error|RSEF1002E Error]]
 +
* [[WDSC tips/MISC#Slightly Faster Startup|Slightly Faster Startup]]
 +
* [[WDSC tips/MISC#Easy Source Upload|Easy Source Upload]]
 +
* [[WDSC tips/MISC#WDSCi Sign Off|WDSCi Sign Off]]
 +
* [[WDSC tips/MISC#The outline view of the RPG (or other) program doesn't show the fields TEXT.|The outline view of the RPG (or other) program doesn't show the fields TEXT.]]
 +
* [[WDSC tips/MISC#List libs, objects, members, etc with descriptions?|List libs, objects, members, etc with descriptions?]]
 +
* [[WDSC tips/MISC#SQL result set only contains 50 rows|SQL result set only contains 50 rows]]
 +
* [[WDSC tips/MISC#I have these strange square symbols in my code.|I have these strange square symbols in my code.]]
 +
* [[WDSC tips/MISC#Run a program on your PC|Run a program on your PC]]
 +
* [[WDSC tips/MISC#Missing Dialogue box in Iseries Command Log|Missing Dialogue box in Iseries Command Log]]
 +
* [[WDSC tips/MISC#Can't remove "work offline" setting|Can't remove "work offline" setting]]
 +
* [[WDSC tips/MISC#Where can I find a list of enhancements in V7?|Where can I find a list of enhancements in V7?]]
 +
* [[WDSC tips/MISC#How do you work through learning the functionality of this application?|How do you work through learning the functionality of this application?]]
 +
* [[WDSC tips/MISC#My workspace is huge!|My workspace is huge!]]
 +
* [[WDSC tips/MISC#WDSC v7.0 LPEX rapidly flashing between multiple source members|WDSC v7.0 LPEX rapidly flashing between multiple source members]]
 +
[[#top]]
 
==External links==
 
==External links==
 
The official WDSC web page [http://www-306.ibm.com/software/awdtools/wdt400/]
 
The official WDSC web page [http://www-306.ibm.com/software/awdtools/wdt400/]

Latest revision as of 21:40, 8 October 2009

This is a dump of tips gathered from the WDSCI-L list.

Additional tips for Lpex can be found here

The tips are split up into sub-pages.

To see the tips please click on a link below.

/Editor

#top

/Compile

#top

/Find


#top

/DEBUG

#top

/SETUP

#top

/MISC

#top

External links

The official WDSC web page [1]

The WDSC Developer blog [2]

WDSC tags on del.ici.ous [3]

Categories