WDSC tips/MISC

From MidrangeWiki
< WDSC tips
Revision as of 17:59, 13 May 2009 by FKOL (talk | contribs) (V7 nosplash)
Jump to: navigation, search

RSEF1002E Error

Operation failed. File system input or output error.

  • Exit WDSCi and reboot your PC.
  • I changed my password recently. For some reason my password got disabled. Also my Netserver password was disabled. (see Disabled User IDs in Netserver via Navigator.)
  • I reset my password, had my Netserver ID enabled and rebooted, all was OK.

original post FKOL 05:17, 11 December 2007 (CST)

#top

Slightly Faster Startup

original post [1] original post [2]

  • Window → Preferences
  • Remote Systems.
  • Then uncheck "Re-open Remote Systems view to previous state"


original post [3]

You can also specify the '-nosplash' parameter in the properties of the shortcut which launches WDSC to suppress the splash screen.

"C:\Program Files\IBM\Rational\SDP\6.0\rationalsdp.exe" -nosplash

for V7 nosplash edit C:\Program Files\IBM\SDP70\eclipse.ini add -nosplash just before -vmargs

-vm
C:\Program Files\IBM\SDP70\jdk\jre\bin\javaw.exe
-nosplash
-vmargs
-Xquickstart
-Xms40m
-Xmx768m
-Xgcpolicy:gencon
-Xscmx96m
-Xshareclasses:singleJVM,keep
-Xnolinenumbers
-XX:MaxPermSize=1536M


#top

WDSCi Sign Off

original post [4]

In 'Remote Systems' view, right-click each connection that's open and click Disconnect

#top

Easy Source Upload

original post [5] (This came from the comment about copying source between systems)


  • There are lots of useful RPG sources posted on the net,
  • But , How do I get that source into my source file.

WELL WDSCi is a really simple method to upload the source.

  • Mark and copy the source you found on the net.
  • In RSE use CRTL+Shift+A to open a source member into your favourite library/file. (Member will be created if it does not exist)
  • Paste the source code and save it (CRTL+S is one way to save)
  • Voila the source is now yours!!

#top


The outline view of the RPG (or other) program doesn't show the fields TEXT.

original post [6]

The outline view of the RPG (or other) program doesn't have any way to show the TEXT associated with the field in a file, but:-

  • You can easily open the Field Table View that does.
  • This will open the iSeries Field Table View which gives all the field information.
  1. Right-click on the line with the F-spec
  2. Select the Show fields menu option.

(Window → Show View → Other → Iseries → Iseries Field Table View)


  • To show the properties of fields in files.
  1. Right click on a physical file object in RSE tree view
  2. and select show in table → fields.


  • If you are using 7.0, you are also able to bring up a Field Table View by highlighting any (PF, LF, DSPF, etc...) file in an RPG program's F-Specs then select Source→Show Fields from the Menu Bar.
  • The above tips only work if the file is externally described in the F specification.

#top

List libs, objects, members, etc with descriptions?

original post [7]

Is there a way to list libs, objects, members, etc in the Remote Systems view with descriptions?

  • The tree view doesn't support this - although if you look at the properties view - you will see the description when an item is selected in the tree view.
  • You should probably try the table view. Window →Show View →Other (or iSeries Table View)
  • This functionality is added by the open source RSE plug-in development available here: RSE-Enhancements (Original WDSC-PLUGIN-DEV post [8].)

#top

SQL result set only contains 50 rows

original post [9]

You need to open the Data View to enable this preference.

  • Window → Preference → Data → Sql Query that lets you specify the maximum number of rows to return,
  • as well as maximum bytes to retrieve for large columns.
  • The default max number of rows is 50.
  • Get V7 if you can.

#top

I have these strange square symbols in my code.

ref PabloMotte, 27 November 2007 (CST)

When you are in RS LPEX, right-click and select Source>Hex Edit line, you will then see the hex value in the iSeries codepage, along with the client codepage.

Also, you can put the cursor on the square, press ESC (to move to the command line) and type "query hex". The "set hex 84" command will set the current cursor position to hex 84 (which turns on 'underline' for the SEU display).

  • Examples of hex codes you can use with "set hex"
    • 80 Normal
    • 81 Inverse
    • 82 White
    • 83 Inverse White
    • 84 Underline
    • 88 Red

#top

Run a program on your PC

original post [10]

There are several programs that come with System i Access for Windows that can be interesting to use, but you can run other programs on your PC too. Those programs are wrksplf, wrkmsg, wrkprt and wrkusrj They are found in the System i Access program folder. On my default install, that is C:\Program Files\IBM\Client Access To register one of these programs in WDSC 7.0.0.x, take the following steps:

  • Run (from the menu.)
  • External Tools and then select (again) External Tools.
  • Click on the Program config once to select it.
  • Click on the New Launch Config icon on the far left (the one with the plus sign) at the top of the panel.
    • In the Main tab:
      • In the Name box I entered the name of the .exe (e.g. Wrksplf)
      • In 'Location' click 'browse file system' and drill to the exe in the IBM Client access folder and select the exe.
      • In 'Working Directory', copy & paste the path and strip off the final slash and the name of the .exe
    • In the Common tab:
      • In the middle, Display in favorites menu, select 'External Tools' and the new application will show up under Run→External tools
    • Click apply, then run to test. Close the app.

When you select Run→External Tools again it should appear at the top of the context menu. You can change the order they appear on the Run→External Tools context menu by using Run→External Tools→Organize favorites

#top

Missing Dialogue box in Iseries Command Log

ref. [[11]]

Sometimes I dont get a dialogue box in the Iseries Command Log View

Use Iseries Commands under Remote Systems View / yoursystem to create a command and run it.

The dialogue box will then pop up in the Iseries command Log.

#top

Can't remove "work offline" setting

original post [[12]]

The connection in question was associated with a Turnover connection.

Created a new RSE connection and associated it with the Turnover one.

Then was able to change the old RSE connection's offline status

We just moved to a new building and cleaned up the TCP/IP stuff, so we have new addresses for our machines. Now when I try to open something through RSE, I receive an EVFC3020W message - Requested information is not available from the cache.



#top


Where can I find a list of enhancements in V7?

original post [13]

You can find the list here: [14]

How do you work through learning the functionality of this application?

original post [15]

  • Currently I'm just stumbling through the basics, and I know I'm not doing many things the most productive way.
  • I recommend that you try the tutorials included in the product as well as the PDM/SEU transition to RSE/LPEX - which was revamped and rewritten for v7.0.
  • Also, if you go to the WDSC web site [16] and search the support section - you will find additional tutorials and the labs from COMMON.
  • Don Nitke ref [[17]] has a site with tutorials .
  • Joe Pluta adds:

You can use the help and tutorials from within the product itself. There are some free tutorials out on the web, including my own first one. You can buy my book, WDSC: Step by Step, which is based on version 5.1.2, but still pretty valid. You can buy my training course from Rochester Initiative which is now available for version 7.

  • You can go to a jumpstart at a technical conference, or an all-day standalone seminar sponsored by your local user group.
  • Or you can contract with someone to come onsite and provide training.

My workspace is huge!

One poster discovered his workspace was very large and wondered if there was a way for WDSC to clean itself up. The suggestion was made to clear out the cache and set a maximum cache size through the preference panel described here.

#top