WDSC tips/SETUP

From MidrangeWiki
< WDSC tips
Revision as of 19:47, 10 September 2008 by FKOL (talk | contribs)
Jump to: navigation, search

Line wrapping problems

original post[[1]]

My source files have 112 byte record lengths, but I really don't want the lines to be that long.

I'd like the CL source to wrap at about 70-75 characters in width.

Enter this command for an 80-wide source data field (the 92 is 80+12 for the 12 bytes at the start of each source line)

set save.textLimit 92


#top

User Actions

Check User Action

#top

What are Profiles and Filter Pools for

Check Profiles, Connections, and Filters

Check RSE filter

#top


Remap Keyboard Shortcuts

Check remap shortcuts

Check WDSC shortcuts

#top

Other Language Setup (Japanese font)

original post[[2]]

The assumption made is that your PC is set up to your preferred languange and the fonts are available on the PC.

  • In Window -> Preferences -> Lpex Editor -> Appearance
  • Change the font to the appropriate language.

#top

Error Installing WDSC 7

original post [[3]]

failed with:

"The installer encountered an error when installing IBM Installation Manager. Installation has discontinued. Return code=-1".

Attempted to install version 7 over 6.

  • Uninstall the Installation Manager
  • On re-install , the Installation Manager was reinstalled and things went good after that.


#top

Missing Filter Option

original post [[4]]

Option to create a filter disappears

This option was present when the workspace was first set up. Today the option wasn't grayed out or anything - it just wasn't there.

This is standard behavior if you have "Show Filter Pools" selected.

#top


Ghost Image for Install V6

original post [[5]]

installing v6 - warning when using ghost images

  • When you install WDSC, it creates a default instance of the WAS 6.1 test server.
  • The config files for the test server are created with the hostname of the PC where the install was done.
  • When the ghost image is then copied to each PC, the config files contains an incorrect hostname and the test server won't start
  • (we always run into this at COMMON and the System i Technical conferences).

You can fix this in one of two ways:

1.

  • Double click on the test server and switch from using RMI to SOAP for the communications.
  • You could do this on the ghost image then it would be set on each copy, although I have never tried this.

2.

  • After the images are installed, edit the file that contains the hostname and update it with the correct hostname (including domain name) for that PC.
  • The file you need to edit is something like:

C:\Program Files\IBM\Rational\SDP\6.0\runtimes\base_v6profiles\default\config\cells\YANTZ1Node01Cell\nodes\YANTZ1Node01\serverindex.xml

You need to update all the hostname and host XML attributes that reference the hostname of the original PC.




#top