WDSCi troubleshooting

From MidrangeWiki
Revision as of 19:58, 11 September 2008 by FKOL (talk | contribs) (Categories)
Jump to: navigation, search

Tips on troubleshooting WDSCi:

First, search the archives


How do I clear the cache?

There are two caches to be cleared:

  • Window > Preferences > Remote Systems > File Cache > Clear-"Clear cached files"
  • Window > Preferences > Remote Systems > iSeries > Cache > Clear-"clear the current cache"
  • NOTE! You must restart your workspace immediately after clearing the cache!

Where is my workspace stored?

File > Switch workspace

Where is the error log stored?

  • In your workspace, in a directory called .metadata, in a file called .log
  • Certain errors are not captured/logged by WDSC, but by the underlying Eclipse platform. There is an Eclipse view that allows you to look at Eclipse errors: Window->Show View->Other->PDE Runtime->Error Log

I'm getting a 'Workspace in use' error

  • Use Windows Explorer and drill down into your workspace.
  • There's a directory called .metadata
  • Inside that directory is a file called .lock
  • Delete that file and restart WDSC.
  • If you can't delete that file, you may have some bits of Eclipse still running.
  • Either reboot your PC or use the Windows task manager to kill eclipse.exe
  • You may also have to kill the Java Virtual Machine, too. It'll be called javaw.exe.
  • Unfortunately, you'll probably have more than one 'javaw.exe'. I'd kill the one using the most memory, but that's no guarantee to be the right one, so watch out! In this case a reboot is a safer mechanism.

Workspace crashes error V6

You should do a back up save of the workspace first.

  • Try deleting the .registry file
  • Shut down WDSCi.
  • Delete the .registry file.
  • When WDSCi restarts it should rebuild the file.
  • Recent install of the Arcad Software plugins and since then most of the iSeries languages are not showing colored tokenization.
  • Upgrade problem from 6.0.0 to 6.0.1.
  • It turned out some of the IBM plugins were not being picked up by Eclipse.
  • Resolved the problem by navigating to:
\IBM\WDSC\6.0\eclipse\configuration
Move the folders named:
org.eclipse.core.runtime
org.eclipse.osgi
org.eclipse.update
To a backup location and then start WDSC.  
This will force it to rebuild its plugin configuration based on what is installed.
  • Assuming the problem is fixed, you can then just delete the folders you moved as they will have been recreated.
  • If this does not fix the problem you most likely need to do a reinstall.

Workspace crashes error V7

You should do a back up save of the workspace first.

  • You could try to delete
\.metadata\.plugins\org.eclipse.core.resources\.snap
and
\.metadata\.plugins\org.eclipse.core.resources\.root\.markers.snap

I have a custom compile command. How do I get the error list back into WDSC?

See the Custom Compile Command tip at WDSC tips

RSEF1002E Error

Operation failed. File system input or output error.

  • Exit WDSCi and reboot your PC.
  • I changed my password recently. For some reason my password got disabled. Also my Netserver password was disabled. (see Disabled User IDs in Netserver via Navigator.)
  • I reset my password, had my Netserver ID enabled and rebooted, all was OK.


Debug SEP and UPDPROD(*NO)

  • Error message, 'Member <membername> cannot be opened while UPDPROD(*NO)'

Try

  • Preferences
  • Run/Debug
  • iSeries Debug,

you'll see an Update Production Files checkbox.


JVM Terminated. Exit Code = 1

The Rational Knowledge Base article 1255195 says that this might be a problem with the cache being used by the -Xshareclasses:singleJVM switch in the eclipse.ini file. Their solution:

To resolve the problem, the corrupted cache needs to be destroyed. It will be rebuilt the next time the product is launched). To destroy the cache:

  1. Open a command prompt.
  2. Navigate to .../SDP70/jdk/jre/bin
  3. Enter the following command:
         * On Microsoft® Windows®:
            javaw.exe -Xshareclasses:destroy
         * On Linux®:
            ./javaw -Xshareclasses:destroy
  4. The product should now launch normally

Outline view file not showing fields

If the outline view of an externally defined file does not show the fields coming from it, check to see that the file is in a library you are authorised to. You will need *CHANGE authority to the library.

Compiles not working: no error, just no compile

Check to see that the back end servers are running:

Right click on the iSeries Objects node of your connection and select "Verify Connection".

Connection to Central service . . . . . . . . . . . . .successful
Connection to Command service . . . . . . . . . . . . .successful
Connection to Data Queue service . . . . . . . . . .successful
Connection to File service . . . . . . . . . . . . . . . .successful
Connection to Record Access service . . . . . . .successful
Connection to Signon service . . . . . . . . . . . . . .successful

If that doesn't help, try changing the job description to log(4 0 *seclvl) and observe the messages in the job log.

If that doesn't work, try compiling interactively to see if the symptoms change: Remote Systems->iSeries->Command Execution

Resolutions reported

  • EVFEVENT file was set to MAXMBRS(1). Normally, it is set to MAXMBRS(*NOMAX).
  • Apparently the root cause is running an iSeries Search without an EVFEVENT file in *CURLIB. The search creates one with MAXMBRS(1).
  • Either delete the EVFEVENT file or use CHGPF to set it to MAXMBRS(*NOMAX).

Categories