WDSC tips

From MidrangeWiki
Revision as of 11:04, 25 June 2007 by Starbuck5250 (talk | contribs) (WDSC tips)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

This is a dump of tips gathered from the WDSC-L mailing list


1. Is there a way to list libs, objects, members, etc in the Remote Systems view with descriptions?

The tree view doesn't support this - although if you look at the properties view - you will see the description when an item is selected in the tree view. You should probably try the table view. Window>Show View>Other (or iSeries Table View)


2. Can I condition page ups and downs by cursor position? Or at least jump the cursor to the top or bottom of the displayed view, then I could roll by line up or down.

Keys can be easily remapped to do other things - check the mailing list archives for discussions on this at length. You'll also want to read the reference help for what LPEX actions are available/do (scrollTop, scrollUp come to mind)

Try this from the archives; [1] How to set an Alt + xx key to position the current line to the top or bottom of your source window. I use the alt page up and down keys, I also have alt + t set to put the current line at the top of the editor window.

Ctrl-t (v7) will put the line where the cursor is at the top of the screen.


3. In SEU, when I hit <enter>, I know it has been saved, even if I lose my session. Do I have to continually save my work?

Remote Systems LPEX Editor has an auto-save feature. Default is set to every 5 minutes. Check out Windows>Preferences, Remote Systems>Remote Systems LPEX Editor

I save every PC document after every few lines. Virtually all PC software recognises Ctrl-S as the 'Save' sequence. I never take my hands off the keyboard...


4. In SEU, when I hit enter, the editor will automatically position my cursor to where I need to key additional data? I know tab moves me to the next input position, but not whether it requires input. And by the time auto syntax checking informs me, I have spent time reading the message, relocating my cursor, etc.

There is no way to currently do this. It is on IBM's list of requirements.

Automatic cursor positioning can be configured by choosing 'Preferences' from the 'Window' menu. In version 7, you are looking for 'Remote Systems -> Remote Systems LPEX Editor -> iSeries Parsers -> ILE RPG'.


5. Do I have to use the mouse to copy lines from one member to another?

Standard windows copy/paste keys can be used, along with a few extras provided in LPEX (check the Edit menu for selection options)

To copy X lines, put your cursor is on the first line of the block you want to move, press Home, then hold Shift and press the down arrow X times. Now press Ctrl+C, then Shift+F6 (this is like Alt-Tab in windows, but for LPEX editor tabs) until you get to the target member. Now find the line you want to insert at, and press Ctrl+V.

Another method not mentioned yet is to mark the lines to copy using Alt-L, and then copy them into position using Alt-C. The lines will be inserted beginning with the line after your cursor position. You should also explore the other Select/Selected functions, which are listed under the Edit menu with their keyboard shortcuts.


6. How can I copy field names in to the member? I added a table to the Table View, I can see all my fields, but can't copy and paste from there.

Drag and drop from table view to RS LPEX is currently not available. It is also on IBM's list of requirements.

You can always open the DDS source and copy the names from there. Be sure to have a look at the rectangle select - it may come in handy for this (alt-r, alt-c.)

7. After compiling, getting errors, and fixing them, and recompiling successfully, the error messages are still showing in the edit view. How can I get rid of them with out closing the member?

Ctrl+F5, or either Source>Remove Errors, or Source>Refresh. Its on IBM's list of requirements to automatically remove these during error list reloads.

Click the X icon in the top left part of the iSeries Error List view.

Remove messages from the source by choosing SOURCE/Remove Messages from the top of the screen. While you have the Error List window open, click on the triangle in the top right corner of the window, choose Show Severity and uncheck Information to not show informational messages. From the same menu, click Messages, choose Insert Selected Only. This will only insert the message you click on from the Error List Window into the source, and will remove the previous error message when you choose another from the Error List Window.


8. The outline view of the RPG (or other) program doesn't have any way to show the TEXT associated with the field in a file. Showing the properties of fields in files would be very nice.

Right click on a physical file object (not sure if it works on logical files yet) in RSE tree view and select show in table -> fields. This will open the iSeries Field Table View which gives all the field information.

Try right-clicking on the line with the F-spec and select the Show fields menu option.

If you are using 7.0, you are also able to bring up a Field Table View by highlighting any (PF, LF, DSPF, etc...) file in an RPG program's F-Specs then select Source->Show Fields from the Menu Bar.

The above two tips only work if the file is externally described in the F specification.


9. Where can I find a list of enhancements in V7?

You can find the list here: [2]


10. How do you work through learning the functionality of this application? Currently I'm just stumbling through the basics, and I know I'm not doing many things the most productive way.

I recommend that you try the tutorials included in the product as well as the PDM/SEU transition to RSE/LPEX - which was revamped and rewritten for v7.0. Also, if you go to the WDSC web site [3] and search the support section - you will find additional tutorials and the labs from COMMON.

Don Nitke has a site with a bunch of tutorials at [4]

Joe Pluta adds: You can use the help and tutorials from within the product itself. There are some free tutorials out on the web, including my own first one. You can buy my book, WDSC: Step by Step, which is based on version 5.1.2, but still pretty valid. You can buy my training course from Rochester Initiative which is now available for version 7. You can go to a jumpstart at a technical conference, or an all-day standalone seminar sponsored by your local user group. Or you can contract with someone to come onsite and provide training.


11. I have these strange square symbols in my code.

When you are in RS LPEX, right-click and select Source>Hex Edit line, you will then see the hex value in the iSeries codepage, along with the client codepage.


12. How do I shift a block of text left/right?

Select the block of text by putting the cursor on the upper left corner of the block. Press Alt-R. Move the cursor to the lower left corner. Press Alt-R again. Do NOT use Windows copy/paste (ctrl-c/x/v) You now have a block of text selected.

You can shift it left/right with alt-f7/alt-f8 If you remap the keys, the action is blockShiftLeft and blockShiftRight You can shift it via the menu Edit, Selected>Shift selection You can uppercase or lowercase it with alt-i/alt-k or via the menu You can move it: position the cursor where you want the upper left corner to end up and press alt-m or use the menu You can copy it with alt-c You can delete it with alt-d

Finally, you can use SEU mode line commands LL and RR typed over the sequence number area. LLnn will shift left nn columns. Note that this will shift the entire line of code, not just a section or block.